Gtk3

Från FriBID
Hoppa till: navigering, sök

GTK3 i FriBID 1.0.1 och senare[redigera]

FriBID 1.0.1 och senare känner av om utvecklingsheaders för GTK 3 är installerat när man kör configure, och använder i så fall GTK 3. Man behöver alltså inte göra något mer än att installera t.ex. libgtk-3-dev på Debian och Ubuntu. Det går också att styra vilken version som används med ./configure --with-gtk=X, där X är 2 eller 3.

GTK3 i FriBID 1.0.0[redigera]

FriBID 1.0.0 har stöd för GTK 3, men som standard så kompileras koden för GTK 2. Vill man använda GTK 3 istället behöver man följande patch:

diff --git a/client/Makefile b/client/Makefile
index 885003a..73c23a3 100644
--- a/client/Makefile
+++ b/client/Makefile
@@ -22,7 +22,7 @@
 
 CFLAGS ?= -O2 -g
 COMMONCFLAGS=$(CFLAGS) -Wall -Wextra -std=c99 -pedantic -Wno-unused-parameter
-PKG_DEPS='gtk+-2.0 >= 2.18' gdk-2.0 glib-2.0 gthread-2.0 $(if $(ENABLE_PKCS11),libp11) libcrypto
+PKG_DEPS='gtk+-3.0' glib-2.0 gthread-2.0 $(if $(ENABLE_PKCS11),libp11) libcrypto
 CCFLAGS=$(COMMONCFLAGS) -I../npapi/include `pkg-config --cflags $(PKG_DEPS)` -DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGSEAL_ENABLE
 # You may have to add -lpthread after $(LDFLAGS) on OpenBSD
 LINKFLAGS=$(CFLAGS) $(LDFLAGS) -Wl,--as-needed
diff --git a/configure b/configure
index 15fc4fd..f61fe45 100755
--- a/configure
+++ b/configure
@@ -234,7 +234,7 @@ fi
 
 # Check that the PKCS#11 module exists
 depError=""
-pkgconfigDeps="gtk+-2.0 >= 2.12;gdk-2.0;glib-2.0;libcrypto;x11"
+pkgconfigDeps="gtk+-3.0;glib-2.0;libcrypto;x11"
 if [ "$enable_pkcs11" = 1 ]; then
     if [ "$optional_pkcs11" = 0 ]; then
         echo "    PKCS#11 smartcard support enabled"